Lab 8: TCP/IP and Wireshark







Name: ______________________
Total points: 155



Packet Capture (Packet Sniffing)
A packet sniffer is an application which can capture and analyse network traffic which is passing through a system’s Network Interface Card (NIC). The sniffer sets the card to promiscuous mode which means all traffic is read, whether it is addressed to that machine or not. The figure below shows an attacker sniffing packets from the network, and the Wireshark packet sniffer/analyser (formerly known as ethereal).
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Packet Analysis
Wireshark is an open source cross-platform packet capture and analysis tool, with versions for Windows and Linux. The GUI window gives a detailed breakdown of the network protocol stack for each packet, colorising packet details based on protocol, as well as having functionality to filter and search the traffic, and pick out TCP streams. Wireshark can also save packet data to files for offline analysis and export/import packet captures to/from other tools. Statistics can also be generated for packet capture files.


Wireshark can be used for network troubleshooting, to investigate security issues, and to analyse and understand network protocols. The packet sniffer can exploit information  passed  in  plaintext, i.e. not encrypted. Examples of protocols which pass information in plaintext are Telnet, FTP, SNMP, POP, and HTTP.

Wireshark is a GUI based network capture tool. There is a command line based version of the packet capture utility, called TShark. TShark provides many of the same features as it’s big brother, but is console-based. It can be a good alternative if only command line access is available, and also uses less resources as it has no GUI to generate.

Using Wireshark to Capture and Analyse Traffic



In this exercise, the fundamentals of the Wireshark Packet Sniffer and Protocol Analyser tool will be introduced. Then Wireshark will be used to perform basic protocol analysis on TCP/IP network traffic.

 (
The
 
Wireshark
 
User
 
Guide
 
can
 be
 
found 
at: 
 
http://www.wireshark.org/docs/wsug_html_chunked/
)



Using Wireshark to Capture Traffic
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Select a Network Interface to Capture Packets through.

Start the Wireshark application. When Wireshark is first run, a default, or blank window is shown. To list the available network interfaces

[image: Table
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[bookmark: _bookmark1]Figure 2 - Wireshark Interfaces Window

 (
Questions
Q:
 
Which Interface
 
is 
connected
 
to
 
a
 
local
 
network
 
(Ethernet)?
Q:
 
What is the interface that is receiving packets? Explain
)










Your answer here:  [5+5 = 10 points]


Generate some network traffic with a Web Browser, such as Internet Explorer or Chrome. Your Wireshark window should show the packets, and now look something like.
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Figure 3 - Wireshark capuring traffic

To stop the capture, select the Capture->Stop menu option, Ctrl+E, or the Stop toolbar button. What you have created is a Packet Capture or ‘pcap’, which you can now view and analyse using the Wireshark interface, or save to disk to analyse later.
The capture is split into 3 parts:
1. Packet List Panel – this is a list of packets in the current capture. It colours the packets based on the protocol type. When a packet is selected, the details are shown in the two panels below.
2. Packet Details Panel – this shows the details of the selected packet. It shows the different protocols making up the layers of data for this packet. Layers include Frame, Ethernet, IP, TCP/UDP/ICMP, and application protocols such as HTTP.
3. Packet Bytes Panel – shows the packet bytes in Hex and ASCII encodings.

 (
Questions
)


 (
Search
 
back
 
through
 
your
 
capture,
 and
 
find 
an
 
HTTP
 
packet
 
containing 
a
 
GET 
command.
 
Click
 
on
 
the
 
packet
 
in
 the
 
Packet
 
List Panel
.
 
Then
 
expand
 
the
 
HTTP
 
layer
 in
 the
 
Packet
 
Details
 
Panel
,
 
from
 
the
 
packet
.
Q:
 
From
 
the
 
Packet
 
Details 
Panel
,
 within
 
the
 
GET
 
command,
 
what
 is
 
the 
value
 
of
 
the
 
Host
 (Destination)
?
 Add an screenshot
Q:
 
Can
 
you see
 
the
 
Hex
 
and
 
ASCII
 
representations
 
of
 
the
 
packet
 
in
 
the
 
Packet
 
Bytes
 
Panel
?
 Add an screenshot
Q:
 
From
 
the
 
Packet
 
Bytes
 
Panel
,
 
what
 
are
 
the
 
first
 
4
 
bytes
 
of
 
the
 
Hex 
value
 
of
 
the
 
Host
 
parameter?
 Add screenshot, be sure to select the GET packet
)

Your answer here [3*5 = 15 points]


To select more detailed options before starting a capture, select the Capture->Options menu option, or Ctrl+K, or the Capture Options button on the toolbar (the wrench). This should show a window such as shown in Figure 4.

[image: Graphical user interface, application
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[bookmark: _bookmark2]Figure 4 - Wireshark Capture Options

Some of the more interesting options are:
· Capture Options > Interface - Again the important thing is to select the correct Network Interface to capture traffic through.
· Capture Options > Capture File – useful to save a file of the packet capture in real time, in case of a system crash.
· Display Options > Update list of packets in real time – A display option, which should be checked if you want to view the capture as it happens (typically switched off to capture straight to a file, for later analysis).
· Name Resolution > MAC name resolution – resolves the first 3 bytes of the MAC Address, the Organisation Unique Identifier (OUI), which represents the Manufacturer of the Card.
· Name Resolution > Network name resolution – does a DNS lookup for the IP Addresses captured, to display the network name. Set to off by default, so covert scans do not generate this DNS traffic, and tip off who’s packets you are sniffing.

Make sure the MAC name resolution is selected. 


[image: Graphical user interface, application, email

Description automatically generated]

Start the capture, and generate some Web traffic again, then stop the capture.


Search through your capture, and find an HTTP packet coming back from the server (TCP Source Port == 80). Expand the Ethernet layer in the Packet Details Panel.

[image: Graphical user interface, text, application
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 (
Questions
Q:
 
What 
are
 the
 
manufacturers
 
of 
your
 
PC’s 
Network
 
MAC address
?
 Show screenshot
Q:
 
What
 
are
 
the 
Hex
 
values
 
(shown
 
the 
raw
 
bytes
 
panel)
 of
 
the
 
MAC address info
?
 Show screenshot
)

Your answer here. [5*2= 10 points]


Wireshark Display Filters.


Right click on the Source Port field in the Packet Details Panel. Select Prepare a Filter->Selected.

[image: ]
Figure 5 - Filtering on a protocol field



Wireshark automatically generates a Display Filter, and applies it to the capture. The filter is shown in the Filter Bar, below the button toolbar. Only packets captured with a Source Port of the value selected should be displayed. The window should be similar to that shown in Figure 6. This same process can be performed on most fields within Wireshark, and can be used to include or exclude traffic.


[image: ]

[bookmark: _bookmark3]Figure 6 - Wireshark Display Filter



Analysing a TCP Session using Wireshark.


Start a capture, and generate some Web traffic by going to www.schneier.com, then  stop the capture. Scroll back to the top of the capture trace. Find the first SYN packet, sent from your PC to the Web Server. This signifies the start of a TCP 3-way handshake.

If your having trouble finding the first SYN packet, select the Edit->Find Packet menu option. Select the Display Filter radio button and enter a filter of tcp.flags. (at this point you should get a list of the flags to choose from). Choose the correct flag, tcp.flags.syn and add == 1. Hit the Find button, and the first SYN packet in the trace should be highlighted.

[image: ]

Note: Find Packet can also be used to search for a Hex signature, such as a malware signature, or to search for a string – such as a protocol command - in the Packet Capture (pcap).

 (
Questions
Q:
 
Can
 
you identify
 
the
 
rest
 
of 
the
 
TCP 
3-way 
handshake
 
easily? (if
 
not
 
read 
on)
)

A quick way to create a Wireshark Display Filter to isolate a TCP stream is to right click on a packet in the Packet List Panel and select Follow TCP Stream. This creates an automatic Display Filter which displays packets from that TCP session only.
It also pops up a session display window, containing by default, an ASCII representation of the TCP session with the client packets in red and the server packets in blue.
The window should look something like Figure 7. This is very useful for viewing human readable protocol payloads, such as HTTP, SMTP, and FTP.

[image: ]
[bookmark: _bookmark4]Figure 7 - Follow TCP Stream Window - ASCII

Change to Hex Dump Mode and view the payloads in raw Hex, as shown below.

[image: ]

Close the popup window. Wireshark now only shows the packets from the selected TCP Stream. You should be able to identify the 3-way handshake easily now.


[image: ]

Note: Wireshark has automatically created a display filter to filter out this TCP conversation. In this case:
(ip.addr eq 192.168.1.2 and ip.addr eq 209.85.227.19) and (tcp.port eq 80 and tcp.port eq 52336)



 (
Questions
Q:
 
From
 
your
 
Wireshark Capture,
 fill in
 
the 
diagram
 
below
 
with
 
the 
IP
 
Addresses
 
and
 Port
 
Numbers
 
for
 
the
 
Client 
and
 the
 
Server
Q:
 
For
 
each
 packet
 in
 the
 
TCP
 
3-way
 
handshake,
 
fill
 in
 the
 
Sequence
 
and
 
Acknowledgement
 
numbers,
 
on
 the
 
diagram
 
below.
)

[9*5 = 45 points] Provide answers below:


Client




Flags: SYN, Seq:  	



Server







IP Address:




Port Number:

Flags: SYN, ACK Seq:  	



Flags: ACK,  Seq:  	

, Ack:  	



, Ack:  	




IP Address:



Port Number:







sdf


5.1.2 Saving Packet Captures


Often captures should be saved to disc, for later analysis. To save a capture, select File->Save As and save the trace. By default this creates a Wireshark pcapng file, or if you select pcap a file many tools can read and write this. For example a tcpdump output file is in this format and can be read into Wireshark for analysis. This saves all the captured packets to the file.

 (
Questions
Q:
 
Did
 
you successfully
 
save
 
your
 
capture
 
to
 disc?
 Show screenshot
Q:
 
Copy the
 
Display
 
Filter 
into 
the 
clipboard,
 and 
close
 
and start
 
Wireshark again,
 
then 
reload the
 
file.
 
Was
 
the 
whole
 
capture
 
saved
 or
 
just
 
the
 
displayed
 
packets?
)


Paste the display filter back into the Filter Bar, and Apply it.
To save only the displayed packets, select File-> Export Specified Packets, and make sure the Displayed radio button is selected rather than the Captured option. This creates a pcap file, with only the packets filtered by the current display filter.

[image: ]

 (
Questions
Q:
 
Close
 
and start Wireshark
 
again,
 
then
 
reload
 
the 
file.
 
Was the
 
whole
 
capture
 
saved
 or
 
just
 
the
 
displayed
 
packets?
)
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)
Your answer here [5 points]


Wireshark Statistics


Start the capture, and generate some Web traffic by going to www.schneier.com, then stop the capture, and select the Statistics->Protocol Hierarchy menu option. A window similar to that shown in Figure 8 should be shown displaying statictics about the pcap. Note that all the packets are Ethernet (Local Area Network) packets, but at the network layer most of the packets are TCP, but some are UDP.

[image: ]
[bookmark: _bookmark5]Figure 8 - Wireshark Statistics Window

 (
Questions
Q:
 
What
 percentage
 
of
 
packets
 in
 
your
 capture
 
are
 
TCP,
 and
 
give
 
an 
example
 
of
 
the
 
higher
 
level
 
protocol
 
which
 
uses TCP?
 Provide screenshot
Q:
 
What
 
percentage
 
of 
packets
 in
 
your
 
capture
 
are 
UDP
 (if any)
,
 and
 
give
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example
 
of
 
the
 
higher
 
level
 
protocol
 
which
 
uses UDP? (use
 
the 
figure
 
below)
)

Your answer here. [5*2 =10 points]
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Select the Statistics->Flow Graph menu option. Choose General Flow and Network Source options, and click the OK button. A window similar to that shown in should be displayed, showing the flow of traffic.
[image: ]
Figure 9 - Wireshark Flow Graph Window



5.1.3 Capture ARP & ICMP Protocol Traffic using Wireshark.


Start a Wireshark capture. Open a Windows console window, and generate some ICMP traffic by using the Ping command line tool to check the connectivity of a neighboring machine (or your home router).

[image: ]

Stop the capture and Wireshark should now look something like Figure 10. 

If you know your Router IP, type ipconfig (NOTE THAT IN WINDOW IT IS IPCONFIG AND LINUX AND MAC IS IFCONFIG) and find the gateway IP



The Address Resolution Protocol (ARP) and ICMP packets are difficult to pick out, create a display filter
to only show ARP or ICMP packets.


 (
Some
 
useful
 
Wireshark
 
display
 
filters
 
can
 
be
 
found at:
 
 
http://wiki.wireshark.org/DisplayFilters
)


[image: ]
[bookmark: _bookmark6]Figure 10 - Wireshark showing ICMP packets

Note the results in Wireshark. The initial ARP request broadcast from your PC determines the physical MAC address of the network IP Address 192.168.1.1, and the ARP reply from the neighboring system. After the ARP request, the pings (ICMP echo request and replies) can be seen.

 (
Questions
Q:
 
After
 
the
 
first
 
ping command,
 are
 
the
 
ARP
 
and
 
ICMP packets
 
captured 
by
 
Wireshark
?
 (You can use a filter 
icmp
 or 
arp
 to see). Provide screenshot
YES/NO
Q:
 
After
 a
 
second
 
or 
third
 ping
 command,
 
is the
 
ARP
 
and 
ICMP
 
packets
 
captured 
by
 
Wireshark
?
ARP:
YES/NO
 
ICMP:
  
 
YES/NO
Q:
 
Why is
 
this?
)

Your answer here. [5*3 = 15 points]


Network Scanning


Network scanning is done at the reconnaissance stage of a structured attack. A network scanner can provide an attacker with information on remote machines which are alive, and that the attacker can communicate with, as well as the services those systems are running. Scanning includes host sweeps/scans, OS scans, port scans and ping sweeps/scans.

A host scan is typically done over an entire network, and reports machines which are alive on the network. A port scan is performed on a single, remote, host system, via its IP Address, and gives information on services running on the machine. Typically an attacker is also looking for which OS the system is running as well as any open TCP and UDP ports (services) which the attacker may be able to exploit.  A network scanning tool, such as nmap, can be used to automatically probe the system for open ports, and give a report back to the attacker.

To mitigate open ports which attackers could use to compromise the system, make sure only services which are necessary are running. Some server OSs have services running by default, such as HTTP (port 80) and FTP (ports 20 & 21) which should be removed when systems are installed. (The command line network utility netstat can be used to check which services are running on the same host).
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Figure 11 Port Scanning a System





Using Wireshark to Capture Network Scanning Traffic




 (
If using Ubuntu, find how to install 
nmap
. 
https://www.howtoforge.com/tutorial/nmap-on-linux/
)


 (
The
 
nmap
 
manual
 is 
available:
 
 
http://nmap.org/book/man.html
)

Start a Wireshark capture. Open a Windows command window, and perform a Host Scan (using ICMP packets) on a neighbours machine using nmap [neighbours ip address] (do not scan the entire subnet). Stop the capture and filter the traffic for ARP and ICMP packets if necessary. Compare the capture with the saved ICMP capture from the previous section.

Note: If you are using MAC (Apple), you need to install nmap doing the following command
		$ brew install nmap

[image: ]
Figure 12 Nmap command line reconnaissance tool

You can change the IP 192.168.1.2 for your router IP. 

 (
Questions
Q:
 
Are
 the
 
packets
 
the 
same
 
as the 
ping
 
packets
 
from
 
the
 
capture
 in
 
the
 
previous
 
section?
Q:
 
What
 type
 
of 
packets
 
are
 
sent
 
by
 
nmap
?
 (You can search online)
Q:
 
Are
 
any
 
other
 
packets
 
sent
 
by
 
nmap
,
 
during the
 
ICMP
 
probe?
 (you can search online)
)

Your answers here. [5*3 = 15 points]

Start a new Wireshark capture, and then perform a host scan (ICMP scan) on a system outwith the subnet, such as
nmap –sP scanme.nmap.org

(do not perform any other type of scan outside the lab subnet). Stop the capture and filter the traffic for ARP and ICMP packets if necessary. Compare the capture with the saved ICMP capture from section 6.

 (
Questions
Q:
 
Are
 the
 
packets
 
the 
same
 
as the 
ping
 
packets
 
from
 
the
 
capture
 in
 
section
 
6?
Q:
 
What
 different
 
types
 
of
 
packets
 
are
 
sent
 
by
 
nmap
?
Q:
 
Are
 
any
 
other
 
packets
 
sent
 
by
 
nmap
,
 
during the
 
host
 
scan? Which
 
protocol
 
and
 
to
 
which
 
port?
)

Your answers here. [5*3 = 15 points]

Start a new Wireshark capture, and then perform a complete Port Scan (in this case a TCP SYN scan) and an Operating System Fingerprint on a neighbours machine using
nmap –O [neighbours ip address]

(do not scan more than a single machine). The –O option should provide the OS running on the scanned machine. Stop the capture and filter for source address == your machines address if necessary. Notice the number and types of ports tried by the nmap port scan. The capture should look something like Figure 13.

[image: ]

[bookmark: _bookmark7]Figure 13 nmap port scan


 (
Questions
Q:
 
Which
 
OS
 is
 
the
 
scanned
 
machine
 
running?
Q:
 
How
 
many
 
ports
 
have
 
been
 
scanned
 in
 total?
 
 
How
 
many
 
are
 
open?
 
Using the
 
nmap
 
manual,
 
or
 
some
 
online
 
research:
Q:
 
Which
 
nmap
 
command allows
 
the 
scanning 
of a
 
custom
 
range
 
of 
ports?
)

Your answer here. [5*3 = 15 points]
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Stream Content

GET /favicon. ico HTTP/1.1
Host: wwi. schneier. com

User-agent: Mozi112/5.0 (windows; U; Windows NT 6.0; en-GB; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET
CLR 3.5.30729)

Accept: inage/png, inage/i9-0.8,%/%4=0.5

Accept-Language: en-gb,en: 4=0.5

Accept-encoding: gzip,defiate

Accept-charset: 150-8859-1,utf-8;0=0.7,
Keep-Alive: 300

Connection: keep-alive

HTTP/1.1 404 Not Found
Date: Sun, 01 Nov 2009 20:25:55 GMT
server: Apache
Mii-webserver : web3
Keep-Alive: Timeout=2, max=9999

fon: Keep-alive
Transfer-encoding: chunked

content-Type: text/html; charset=iso-8859-1
116

|<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>

<TITLE>404 Not Found</TITLE>

</HEAD><BODY>

<HL>NOT Found</H1>
The requested URL /favicon.ico was not found on this server.<e>
<HR>

<ADDRESS>Apache/1.3.34 Server at www.schneier.com Port 80</ADDRESS>
</BODY></HTHL>

[Eind][Sove s][print] entire conversation (23197 bytes) | © ASCI © EBCDIC © HexDump © € Arrays

Filter Out This Stream Close
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Stream Content
UGy 7T U U £ 33 YU UE ST U3 U3 UI T T U T US iR
000000F0 63 6f 64 69 6e 67 3a 20 67 7a 69 70 2c 20 64 65 coding:
00000100 66 6 61 74 65 0d 0a 41 63 63 65 70 74 2d 43 68 flat
00000110 61 72 73 65 74 3a 20 45 53 4 2d 38 38 35 30 2d arse
00000120 31 2¢ 75 74 66 2d 38 3b 71 3d 30 2e 37 2c 2a 3b 1,utf-8
00000130 71 3d 30 2e 37 0d 0a 4b 65 65 70 2d 41 6 60 76 G=0.7..K
00000140 65 3a 20 31 31 35 0d 0a 43 6f 6e 6e 65 63 74 69 e: 115.. Connecti
00000130 GF G 32 20 G 69 63 70 2d 61 ec €9 76 €3 0d 0a ony keep -alive,
00000160 52 03 B8 §5 72 05 72 33 20 68 74 74 70 3a 2f 2f Referer: hrtp U
30000150 31 33 35 56 31 30 38 26 31 6 51 3f e¢ &1 6k &7 roveise: 11/%ang
00000180 5f 63 68 65 63 6b 2e 68 74 6d 6c 0d 0a 41 75 74 _check.h tml..Aut
00000190 68 6F 72 69 7a 61 74 69 6f 6e 3a 20 42 61 73 69 horizati on: Basi
000001A0 63 20 59 57 52 74 61 57 34 36 63 47 46 7a 63 33 C YWRTaW 46CGFzC3
00000180 64 76 63 6d 51 3d 0d 0a 50 72 61 67 6d 61 3a 20 dvcma-.. Pragma:
000001C0 6Ge 6f 2d 63 61 63 68 65 0d 0a 43 61 63 68 65 2d no-cache ..Cache-
00000100 43 6f Ge 74 72 6f 6C 3a 20 6e 6f 2d 63 61 63 68 Control: no-cach
000001E0 65 0d 0Oa 0d 0a Ciges
00000000 48 54 54 50 2 31 2e 30 20 34 30 31 20 55 6e 61 HTTP/1.0 401 Una
00000010 75 74 68 6 72 69 7a 65 64 Od Oa 53 65 72 76 65 uthorize d..serve
00000020 72 3a 20 75 68 74 74 70 64 2f 31 2e 30 2e 30 0d r: uhttp d/i.0.0.
00000030 0a 44 61 74 65 3a 20 53 61 74 2c 20 30 31 20 4a .Date: 5 at, O1 J
00000040 61 6e 20 32 30 30 30 20 30 31 3a 32 30 3a 32 36 an 2000 01:20:26
00000050 20 47 4d 54 0d 0a 57 57 57 2d 41 75 74 68 65 6e GMT..ww W-Authen

A
T

00000060 74 69 63 61 74 65 3a 20 42 61 73 69 63 20 72 65 Basic re
00000070 61 6c 6d 3d 22 4e 45 54 47 45 41 52 20 57 4e 52 GEAR WNR
00000080 31 30 30 30 76 32 22 0d 0a 43 6F 6e 74 65 be 74 _Content
00000090 2d 54 79 70 65 3a 20 74 65 78 74 2f 68 74 6d 6C ext/html

00000040 3b 20 63 68 61 72 73 65 74 3d 22 55 54 46 2d 38
00000080 22 Od 0a 43 6F 6e 6e 65 63 74 69 6f 6e 3a 20 63
000000c0 6¢ 6 73 65 0d 0a Od 0a 3c 48 54 4d 4c 3e 3c 48
00000000 45 41 44 3e 3c 4d 45 54 41 20 68 74 74 70 2d 65
000000EQ 71 75 69 76 3d 27 50 72 61 67 6d 61 27 20 63 6F
000000F0 6e 74 65 6e 74 3d 27 6e 6f 2d 63 61 63 68 65 27
0000NT0N 26 2 4d 45 54 41 50 AR 74 74 70 3d A 71 75 RA

(i [sovets [

FronTssien ] (o

UTE-8

Entire conversation (993 bytes)
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il (Untitled)

Ele Edit View Go Capture Analyze Statistics Telephony Tools Help
Suoes BDEaxX2S “EPDTF L Blaaad a@®mk B

Fiter: | (ip.addr eq 192168.1.2 and ip.adir eq 209.85.227.19) and (tcp.port eq8| v Expression... Clear Apply

No. Time . Source Destination Protocol Info.
52336 > NCTp_|5VN] Seq=0 WIn-8192 Len-0 MSS=1460 Ws=2_
Rttp > 52336 [SYN, ACK] Se
52336 > hrtp [ACK] Seq=1 Acl

3 .85.227.19 B
10.203764 192.168.1.2 200,

9 10.204038 192.168.1.2 209.85.227.19 [TCP segment of a reassenbled pou]

10 10.204049 192.168.1.2 209.85,227.1 POST /mai1/?ui=2&1k=F7bcffbddseview=t1&start=0&num=70&auto=1&ver—xv_v
11 10.267626 209.85.227.19 192.168.1.2 http > 52336 [ACK] Seq=1 Ack=1431 Win=8640 Len-0

12 10.270788 209.85.227.19 192.168.1.2 http > 52336 [ACK] Seq=1 Ack=1738 Win-11456 Len-0

13 10.422381 209.85.227.19 192.168.1.2 [TCP segment of a reassenbled PDU]

14 10.423510 209.85,227.19 192.168.1.2 [TCP segrent of a reassenbled PDU]

15 10.423582 192.168.1.2 200.85.227.1 52336 > http [ACK] Seq=1738 Ack=2724 Win=17160 Len=0

16 10.425534 209.85.227.19 192.168.1.2 [TCP segment of a reassenbled PDU]

7 10.426887 209.85.227.19 192.168.1.2 [TCP segrent of a reassenbled PDU]

18 10.426926 192.168.1.2 200.85.227.1 52336 > http [ACK] Seq=1738 Ack=5584 Win=17160 Len=0

19 10.475452 209.85.227.19 192.168.1.2 [TCP segment of a reassembled PDU]

20 10.477304 209.85.227.19 192.168.1.2 [TCP segrent of a reassenbled PDU]

21 10.477348 192.168.1.2 209.85.227.19 52336 > http [ACK] Seq-1738 Ack=8444 Win=17160 Len=0 =

@ Frame 5 (66 bytes on wire, 66 bytes captured)
@ Ethernet I1, src: LiteonTe_ag:f5:Se (00:22:5f:a0:f5:5e), Dst: Askeycom e 2 (00:16:€3:ed:55:92)
Internet Protocol, src: 192.168.1.2 (192.168.1.2), Dst: 209.85.227.19 (209.85.227.19)
© Transmission Control Protocol, src Port: 52336 (52336), Dst Port: http (80), Seq: 0, Len:
source port: 52336 (52336)
pestination port: http (80)
[stream index: 1]
sequence number: 0 (relative sequence number)
Header Tlength: 32 bytes
0x02 (SYN)

0
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[ Wireshari: Export Specified Pac
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= Computer (1)
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Network
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Selected packet
Marked packets
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Range:

Remove lgnored packets
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W Wireshark: Protocol Hierarchy Statistics .. =) P

Display fifter: none.
Protocol Packets Bytes Mbit/s End Packets End Bytes End Mbit/s
& Frame 28 92630 0018 0 L)

© Ethemet 228 92630 0018 0 L)

) Internet Protocol 0018 0 0 0000

n Control Protocol
I

) Hypertext Transfer Protocol

Line-based text data 2 257 0001 2 % oo
Compuserve GIF 2 25 0000 2 # o
Internet Group Management Protocol PR ) s m o
& User Datagram Protocal 6 60 0000 0 o oo
Domain Name Service 6 60 0000 6 &0 000
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[ (Untited) - Graph Analysis

Time.

0.000
0046
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i
(45s2l)w (sn)
=
(a5821)" (Sn)
st n e
(45&2!) (Sn)
T
prove oo
hitp > 45621 [ACK
(45s2l)w (sn)
prove oo
s> untace
pro! oo
(a5821)" il TorEn (Sn)
ey petotar
(a5821)" TP semhent ofa ¢ (80)
e
pro! oo
(a5821) TP seathent ofa ¢ (80)
"—‘—“‘”—mm o
pro! oo
prove oo
e JR P T

Comment

DHS: Standard query A winschaeier.com
DHS: Standard query response A 204.11.246.48
TCP: 45821 > hitp [SVN] Seq=0 Win

TCP: hitp > 45821 [SVM, ACK] Seq=0 Ad
TCP: 45821 > hiep [ACK] Seq=1 Ack=1 Wi
HTTP: GET /faviconico HTTP/1.1

TCP: hitp > 45821 [ACK] Seq=1 Ack=373 Wi
HTTP: HTTP/1.1 404 Not Found (cext/hemi)

17184 Len=0

TCP: 45821 > hitp [ACK] Seq=373 Ack=520 Win=16664 Len=0
HTTP: GET Jcrypto-gram-back html HTTP/1.1

TCP: [TCP segment of a reassembled PDU]

TCP: [TCP segment of a reassembled PDU]

TCP: 45821 > hitp [ACK] Seq=785 Ad

284 i

7184 Len=0
TCP: [TCP segment of a reassembled PDU]

TCP: 45823 > hitp [SYN] Seq=0 Win=8192 Len=0 MSS=1460 Ws=2
85 Adk

TCP: 45821 > huep [ACK] Seq

516 Wi

7184 Len=0

TCP: [TCP segment of a reassembled PDU]
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:\Users\Rich>ping 192.168.1.1

Pinging 192.168.1.1 with 32 hytes of data
Roply from 192.168.1.1: bytes=32

Reply from 1921168 1

Reply from 1921168 1
[Rep1y from 192.168.1.1: hytes=32

Ping statistics for 192.168.1.1:
Packets: Sent - 4, Received = 4, Lost = B (B loss).
Approxinate round trip times in milli-seconds:
Mininum = ins, Maxinum = 4ns. Average = ims

:\Users\Rich>_
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Command Prompt

ticrosoft Windows [Version 10..18362.418]
(c) 2019 Microsoft Corporation. All rights reserved.

BN e

tindows TP Configuration

Ethernet adapter Ethernet:

Connection-specific DNS Suffix
Link-local IPvé Address .
1Pva4 Address.

Default Gateway
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[ (Untitied) - Wireshark w P ¥ TV - ——— - . -
Ele Edit View Go Copture Analyze Statistics Telephony Tools Help

Seoed BDEXEE AesdTL

laee | #B®% 8

| v Bpression... Clear Appy
Source Destnation brotocel_Info
LiteonTe_a9:f5:5e Broadcast ARP who has 192.168.1.17 Tell 192.168.1.2
LI(&onTLa f5:5e ARP 192.168.1.1 1

i

LiteonTe_a9:f5:5e (00:22:5f:a9:f5:5e), Dst: Askeycom_ed:55:9a (00:16:e3:ed:55:9a)

Ethernet II, src:
Tnternet Protocol, Src: 192.168.1.2 (192.168.1.2), Dst: 192.168.1.1 (192.168.1.1)

© Internet Control Message Protocol
8 (echo (ping) request)

100
checksum: Ox4dad [correct]
Identifier: 0x0001

Sequence number: 14 (0x000€)
5 pata (32 byts)

[Length: 321

0000 00 16 e3 ed 55 9a 00 22
0010 00 3c 5d aa 00 00 80 01
0020 01 01 08 00 4d

0030

0020

5f ag f5 5e 08 00 45 00
59 c3 0 a8 01 02 cO a8
00
5
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:\Progran Files\Nnap>nnap 192.168.1.2
[starting Nnap 4.68 ¢ http://insecure.org > at 2088-94-29 BB:52 GNI Standard Time|

STATE SERVICE
open  Ftp

open  sntp

open http

open  msrpe

open nethios—ssn
open

open

inap done: 1 IP address <1 host up> scanned in 1.982 seconds

\Progran Files\Nnap>_
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Progran Files\Nnap>nmap 192.168.1.2
Starting Nnap 4.68 ¢ http://insecure.org > at 2088-84-29 88:52 GMT Standard T

Interesting ports on 192.168.1.2:
Not shoun: 1787 closed ports

PORT STATE SERVICE

21/tcp  open ftp

25/tcp  open sntp

88/tcp  open http

135/tcp open msrpe

{39/¢cp open nethios—ssn

443/tcp open https

445/tcp open microsoft-ds

1825 tcp open NFS-or-I18

MAC Address: @0:0C:76:27:0A:A4 (Micro-star International CO.)

Nnap done: 1 IP address (1 host up) scanned in 1.982 seconds
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(Untitled) - Wireshark = I]x)
fle Et Vew o Coplwe dnaiyze Stasios teh

Suoee BEXRE A¢+TLEBEB QQAQAA | $#EB X B

Eer [eth st == 0010532525581 |+ Exoression... Clear oy

No. . Time. Source. Destination Protocol  Info L
66903208  192.168.1.11 192.168.1.1 uoe Seurce part: edtools Destination port: npp
86916912  192.168.1.11 1521168.1.1 TR NTR client E
56032152  192.168.1.11 1521168.1.1 uoe Seurce part: fuscript Destination port: 11487 2
10 6.047818  192.168.1.11 1521768.1.1 uoe Source port: xd-icue Destination port: jas-reg
11 6.963287  192.168.1.11 1521168.1.1 uoe Seurce port: audit-transfer Destination port: glob
12 6.670033  192.168.1.11 1521168.1.1 uop Source part: capioverlan Destination part: Filanet
13 6.954805  192.168.1.11 1521168.1.1 ECHO  Request
14 7.010220  192.168.1.11 1521768.1.1 RPC Continuation
15 7.025875  192.168.1.11 1521168.1.1 uop Seurce part: blaze Destination port: vat
167.042041  192.168.1.11 1521168.1.1 uoe Source unizensus  Destination port: 32785
17 71057147 192.168.1.11 1521168.1.1 uoe Source winpaplanmess Destination part: 3278
18 7.072728  192.168.1.11 1521768.1.1 uoe Source cl222-acse Destination port: 1028
15 7.083480  192.168.1.11 1521168.1.1 uoe Source resacommunity Destination part: 1027
207104024 192.168.1.11 1521168.1.1 uoe Source nfa pestination port: ilss
21 7119653 192.168.1.11 1521168.1.1 uoe Source fascontrol-oms pestination port: mic
22 7135380  192.168.1.11 1521168.1.1 uoe Source port: ascontral Destination part: pcanywhe
53 7' TsaR7a 105 TAR 11 a5 TR 1T s Srannard iy TYT wersinn hind

m | >

® Frame 3 (60 bytes on wire, 60 byres captured
® Ethernet IT, Src: Intel_63:ce:53 (00:07:e0:63:ce:53), Dst: Cisco_25:25:6f (00:1h:53:25:25:6f
® Internet Protocol, Src: 192.168.1.11 (192.168.1.11), Dst: 102.168.1.1 (192.168.1.1)

® Internet Control Message Protocal

0000 00 1b 53 25 25 6F 00 07 20 63 ce 53 08 00 45 00
0010 00 28 CB 07 00 00 40 01 2f 7L O a8 01 Ob O a8
0020 0L 01 0d 00 4b 55 02 00 00 01 f0 0 f0 fO O 0
0030 f0 o fo f0 O F0 00 00 00 00 00 00

File: "CDOCUME~ 1imILOCALSTemplether)... | Packets: 87 Displayed: 80 Marked: 0 Droppe 0 Profie: Default
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