
To complete the objectives, you will need to complete the step by step tutorial (4 points) and 
the critical thinking section (6 points), ensuring the website is fully functional.


After successfully completing this tutorial, you should be able to:


• identify key elements of Dreamweaver’s interface.

• create and link a CSS style sheet to an HTML file using Dreamweaver.

• use Dreamweaver’s CSS Style Window to create & edit CSS rules in an external style 

sheet.

• review default properties of standard HTML tags and explain how to modify them.


1. Please read this tutorial thoroughly. There is important information that is in your best 
interest to understand and retain.


2. You will make use of Dreamweaver CC and a browser of your choice (Firefox or Safari) to 
preview your webpages.


 

Page  of 1 11

First Dreamweaver Site 
        creating a website using HTML and CSS

Objectives

Get Started

It is important that you type the code and content, and not to copy and  paste 
from the lab. Copying will most likely cause errors in your markup and cause you 
to miss valuable info.

Note

Create a New HTML file

1. Create a new folder on your desktop. Label that folder as instructed. This is where you 
need to save all of your HTML and CSS files for this lab.   

2.    Launch Dreamweaver CC.  Create a new html page by choosing file > new from the

       main menu. In the General section, choose Blank Page > HTML, then click create. 

       Go to the top right of the menu bar and select “standard” from the drop down menu                             
	 (see green arrow on Page 3).






1. Open the Properties Panel (Window > Properties). Type “My First Dreamweaver Site” in the 
“Document Title” textfield. Alternatively, you can type “My First Dreamweaver Site” directly 
in the code view (see red arrow below in Figure 1)   
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3.    Save the file as index.html into the folder you created on your desktop above. Follow

       convention of naming your home page as index.html


4.   You should be viewing the HTML pages in split mode, that enables you to see the code in

       the Code window and the visual representation of the code in the Design window at the            

       same time. Go to View Menu > Split > Code-Design (also known as split mode).

The Content

Figure 1



2. Click on the “Design” tab so that you are now working in the “Design” window. Type the 
following content. (See example below).


3. After completion, save, preview, and refresh using a browser, by clicking on the globe icon 
located on the bottom-right side of the device preview. If Safari or Firefox is not in the list, 
choose the edit browser list option. There you can add browsers to the list by pressing the plus 
sign at the top of the dialog box. Browse for the desired browser in the Applications folder, 
then choose Open and OK.
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 Home Page  (click return) 

 Navigation (click return) 

 home (click return) 

 about (click return) 

 contact 

This is my practice website. I am just learning, so it is basic. This page is written in HTML, 
and its presentation is controlled by an external Cascading Style Sheet. Currently, I am 
reading the book “HTML and CSS” by Jon Duckett to learn the fundamentals of website. 

Figure 2



1. In the Design Window, select the first line of content (Home Page), then use the properties

    bar to change the Format to Heading 1. If the properties window isn’t open, choose

    Window > Properties from the Menu Bar. Notice the new tags in the Code Window.


2. In the Design Window, select the second line (Navigation). Using the properties bar,

    change the Format to Heading 2. Notice the new tags in the Code Window.


3. In the Design Window, select the next three lines of content (home, about, 
    contact). Using the properties bar, change them into a list by clicking

    the unordered list button (Figure 4a). Notice the new tags in the Code Window.


4.  After completion, save, preview, and refresh using a browser of your choice


Use the content below and the experience of creating the first page to create and markup two 
more pages naming them “about.html” and “contact.html”. Save both pages in the same 
folder that has the index.html file.  Examples are below.
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Other Pages

  
 About Me  

 Navigation
• home 
• about 
• contact 

So far there is not much to know. I am taking Front End Dev I course and I love it.  
 Please add your own story here..

Format Content

Figure 3

Figure 4a

h1

h2

list

p
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 Contact Me  

 Navigation
• home 
• about 
• contact 

If you would like to get in touch, here is my info: 
• phone: 555-678-2345 
• e-mail: firstname.lastname@gmail.com

h1

h2

list

p

list

A web site is a group of hyperlinked web pages. The unordered list on the page will eventually be 
a list of hyperlinks which, when clicked, should take the user to the other pages in your site.

1.  Using Dreamweaver, open the index.html page.

2.    In the Design Window select the second list item (about).

3.    In the Properties Window, there is a field labeled link. Click the folder icon next to it and 
       browse to find the about.html file located in this lab’s start folder. Choose the file to  
       create the link.   
4.   Preview in browser and test the link.

5.   Repeat the above procedure for all of the list items, linking them to their corresponding pages.

6.   Preview in browser and test the links.

7.   Repeat the above procedure for the contact.html and about.html pages.

8.   Preview in browser and test all of the links.

Anchoring Pages

Figure 4b

mailto:me@gmail.com


Now that the content is taken care of, let’s make the site a bit more presentable using CSS.


1.   Go back to Dreamweaver. Select File > New from the Main Menu. In the General section,

      Choose Blank Page > CSS, then click to create.


2.   Select File > Save As, naming it “Allpages.css” in the same folder (directory) as your 
index.html file.


3.   Return to the index.html file and click to make it active. You will link the CSS file to your

      index.html file.


4.   Open the CSS property panel by selecting Window > CSS Designer from the Main Menu

      (in Dreamweaver). This is the CSS control center used to create and edit rules or selectors. 


     





Figure 5 

7.   You may also note that there is a new link tag (Allpages.css) in the head of the

      index.html file.  You can see the same from the code view. 
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Creating and Linking CSS file

When you edit with this window you’re writing rules in an external sheet. 
That sheet is independent of Dreamweaver, so if you want to type, edit items, 
  or arrange them, you can open the sheet and do so at any time.

Note

5.   Click on the + sign at the top of CSS Designer panel. Choose “Attach existing CSS file”

      (see Fig 5)


6.   Browse and locate “Allpages.css” file. Click OK. Note that the CSS file should appear

      in the window panel of the CSS Designer — an indication that the link was effectuated

      accurately.




Selector for the h1 tag 

1. The first selector we shall create is one for the standard tag, h1. 

2. To create an h1 selector for the website, make sure that “Allpages.css” is highlighted (by 
clicking it obviously) in the CSS Designer panel. Next, click on the  “+” sign in the Selectors 
panel, and you will be prompted with the relevant selector such as “body h1.” You can 
delete the “body” from the h1 tag.


3. You will need to add some properties to all the content in the webpage defined by the h1 
tag.


4. Set the following properties for the h1 tag, as shown below (Table 1). (Make sure that h1 tag  
is highlighted in the Selectors panel by clicking it). An example of what the first rule should 
look like is provided to the right of Table 1. Make sure that the “Show Set” in the 
Propertied panel checkbox is not selected.








    	              Table 1


5.   Save, preview, and refresh your browser.
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Creating Selectors

  
• Text -> font-weight: normal; 
• Text -> font-size: 25px; 
• Text -> color: #0099CC; 
• Layout -> margin-top: 0px; 
• Layout -> margin-bottom: 50px;

Figure 6



The body Selector 

6. Create a new selector for the body tag and set the following properties shown in Table 2:
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• Text -> font-family: Arial, Helvetica, sans-serif; 
• Background -> background-color: #cccccc; 
• Layout -> margin: 0px; (same for all) 
• Layout -> padding: 50px; (same for all)

When we say margin: 0px; this implies that margin-top:0px; margin-left: 0px; 
margin-right: 0px; margin-bottom: 0px; If you want all four margins to have same 
value, click in the middle of the square (Fig 7) to toggle between “click to change all  
the properties and click to change specific properties”


Note

Table 2

Figure 7

7.   Save, preview, and refresh your browser.



The h2 Selector 

8.   Create a new Selector for the h2 tag and set the following properties shown in Table 3:
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• Text -> font-weight: normal; 
• Text -> font-size: 10px; 
• Text -> color: #0099CC; 
• Text -> text-transform: uppercase;

9.   Save, preview, and refresh your browser.


The p Selector 

10.  Create a new selector for the p tag and set the following properties shown in Table 4:


11.   Save, preview, and refresh your browser.


The a Selector 

12.  Create a new selector for the a tag and set the following properties shown in Table 5:


13.   Save, preview, and refresh your browser.

  
• Text -> font-size: 12px; 
• Text -> color: #666666; 

Table 3

Table 4

  
• Text -> text-decoration: none; 
• Text -> color: #FF9900; 

Table 5



The <ul> Selector 

14.   Create a new selector for the ul tag and set the following properties shown in Table 6:
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• Text -> list-style-type: none; 
• layout -> margin-top: 0px; 
• layout -> margin-right: 0px; 
• layout -> margin-bottom: 30px; 
• layout -> margin-left: 0 px; 

Table 6

15.   Save, preview, and refresh your browser.

The <li> Selector 

16.   Create a new selector for the li tag and set the following properties shown in Table 7:

  
• layout -> display: inline; 
• layout -> margin-top: 0px; 
• layout -> margin-right: 20px; 
• layout -> margin-bottom: 0px; 
• layout -> margin-left: 0 px; 

17.   Save, preview, and refresh your browser.

Table 7






Change the position of all the content in all the HTML pages by adding the following 	 	
properties to the body definition in your CSS page (see Table 8).


1. Change the contents of the website based on a topic of your choice by including 	 	 	
your own text and at least two images to provide context. Include ample amount of 
contents in your index.html and about.html pages to engage the user. At least two 
paragraphs are recommended in index and about webpages. The two images must be 
two different sizes to create variety in your site. (3 points) 

2. Create a definition (CSS rule) to target the seven digits of the phone number and the 	 	
email address to change their appearance (text color) to #FF7D33 and font-size to 12 
pixels. (2 points) 

3. Modify the size of the web page to 960 pixels wide and center the website container 	 	
(not the contents) on your monitor. Do not center-align the contents of the site. (1 point)


Test the website by previewing it in Firefox, Chrome or Safari browser.
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You may have noticed that the other web pages are not linked to the CSS page you just created 
and edited.


1. To change the presentation of the other two HTML pages, link them to the Allpages.CSS 
file using the previously described process.  


2. Save, preview, and refresh.


You receive 4 points if you complete the above successfully.


Linking the CSS to other pages

Critical Thinking

 body { 
     background-color:#cccccc; 
     font-family: arial, Helvetica, sans-serif; 
     margin: 0px; 
     padding: 50 px;  
 }

Table 8


