Getting Started with THE GIMP
Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.
Mac and Mac OS are trademarks of Apple Inc., registered in the U.S. and other countries.
UNIX® is a registered trademark of The Open Group.
Windows is a registered trademark of Microsoft Corporation in the United States and other countries.
# Table of Contents

**About This Tutorial** ................................................................................................................. 5  
Organization .......................................................................................................................... 5  
Assumptions .......................................................................................................................... 6  
Conventions ........................................................................................................................... 6  

**The GIMP Basics** ............................................................................................................. 7  
Working with Image Files ...................................................................................................... 7  
Working with Layers ............................................................................................................. 8  
Working with Filters .............................................................................................................. 9  
Working with Color ............................................................................................................... 9  

**Getting Started** ............................................................................................................. 11  
Starting the GIMP .................................................................................................................. 11  
Creating a New File .............................................................................................................. 16  
Opening a File ....................................................................................................................... 17  
Using Undo ............................................................................................................................ 18  
Saving a File .......................................................................................................................... 19  
Exiting the GIMP .................................................................................................................. 21  

**Creating a Pencil Sketch from a Photo** ............................................................................ 23  

**Index** .................................................................................................................................. 30
About This Tutorial

The GIMP (GNU\textsuperscript{1} Image Manipulation Program) is a free program to create and edit digital images. You can use the GIMP to touch up photos, lay out web pages, make digital art, produce logos, create animations, and perform many other useful and creative graphic functions. The shadow effect used on the cover title and the screen shots used throughout this tutorial were produced using the GIMP.

The GIMP is available for the Linux, Unix, Windows XP, and Mac OS X operating systems.

This tutorial gives an overview of some basic digital editing concepts and shows you how to get started using the GIMP.

This tutorial gives you a brief introduction to some digital editing concepts, shows you how to perform basic GIMP operations, and leads you through an example.

The digital editing concepts — working with image files, layers, filters, and color — are explained and then demonstrated in the example that follows. The example gives step-by-step instructions for creating a pencil sketch or drawing from a color photo.

Organization

This tutorial contains these sections:

- The GIMP Basics: a brief discussion of working with image files, layers, filters and color. This background is presented to enable you to understand the instructions that come later; it is not a thorough treatment of these topics.
- Getting Started: step-by-step instructions for starting and exiting the GIMP, opening and saving files, and using the GIMP undo function.
- Creating a Pencil Drawing: step-by-step instructions for creating a pencil drawing from a photo so you can practice using the GIMP’s digital editing features.

\begin{footnote}{\textsuperscript{1} GNU (pronounced g-noo) refers to a project called “GNU’s Not Unix” that produced the free software operating system called Linux. The Gimp was first distributed with Linux but is now available for other platforms as well.}\end{footnote}
Assumptions

This tutorial makes two assumptions about your readiness to begin using the GIMP:

- This tutorial assumes you have the GIMP already installed on your computer. If you don’t, check the system requirements and follow the download and installation instructions found on the GIMP website http://www.gimp.org.

- This tutorial assumes you have a photo already loaded onto your computer. If you don’t, these are some of the ways you can get one: upload a photo from your digital camera, import a picture using a digital scanner, download an image from the web, or ask a friend to email you a photo.

Conventions

The step-by-step instructions for the examples in this tutorial use these conventions:

<table>
<thead>
<tr>
<th>Instruction:</th>
<th>Action:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Click the left mouse button.</td>
</tr>
<tr>
<td>Double-click</td>
<td>Click the left mouse button twice in rapid succession.</td>
</tr>
<tr>
<td>Right-click</td>
<td>Click the right mouse button.</td>
</tr>
<tr>
<td>Ctrl-Key</td>
<td>Press the Ctrl key and the indicated key simultaneously.</td>
</tr>
</tbody>
</table>

Because images on the web may be subject to copyright, get permission from the image’s creator before using one.
The GIMP Basics

Before you begin using the GIMP, it’s helpful to understand some common digital editing terms and concepts.

This section is designed to give you a basic understanding of working with images, namely, working with image files, layers, filters, and color. There are many other important aspects to working with images, but these are the ones most relevant to creating the effects demonstrated in the example and are enough to get you started using the GIMP. A complete discussion of these topics is beyond the scope of this tutorial, but can be found in many books, articles, and other references pertaining to digital graphics editing.

The best way to learn the GIMP is to go through a step-by-step example like the one in this tutorial, then experiment on your own.

Working with Image Files

Digital images are stored on your computer using special file formats. The most commonly used file formats are GIF and JPEG, and to a lesser extent, PNG. Generally speaking, the differences among them have to do with the number of colors, level of detail, and types of images they can handle, and whether or not they are widely supported by the major internet browsers. Other technical considerations such as file compression play a role too.

JPEG files are used for storing images with lots of color and detail like photos, while GIF supports drawings and simple artwork that use fewer colors. GIF is the standard image file format for the web. JPEG files can be used as well, but they tend to be larger and take longer to load into your browser.

PNG is a newer file format that improves upon GIF and will grow in popularity as browser support increases.
The GIMP works with these, and many more, files types:

<table>
<thead>
<tr>
<th>File Type</th>
<th>GIF</th>
<th>JPEG</th>
<th>PNG</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Extension</td>
<td>.gif</td>
<td>.jpg</td>
<td>.png</td>
</tr>
<tr>
<td>Colors</td>
<td>8-bit (256 or fewer colors)</td>
<td>24-bit (millions of colors)</td>
<td>8-bit, 24-bit, or 32-bit</td>
</tr>
<tr>
<td>Best suited for:</td>
<td>Flat color images, line art, and typography.</td>
<td>Continuous tone graphics, photographs, and anything with soft and blurry edges</td>
<td>Flat color images, line art, and typography</td>
</tr>
<tr>
<td>Browser Support</td>
<td>Widely supported</td>
<td>Widely supported</td>
<td>Emerging</td>
</tr>
</tbody>
</table>

The GIMP supports dozens of other file types besides the three mentioned here. The GIMP has its own file type called GIMP XCF. If you are working with a file and want to save it and come back to it later, GIMP XCF is the file format you should use because it preserves layers. (Layers are explained in the next section.) When you have finished your work, you can export the image to a different format.

**Working with Layers**

You can think of a layer as a single transparency or sheet of acetate on which you can draw or paint. Layers are stacked on top of one another, and each layer can affect the look of the layers below it. In digital editing, layers are used to separate the elements in an image so you can work on one part of an image without affecting the rest. For example, by using layers you can adjust the color in one part of your image without disturbing the color anywhere else.
You can make a layer completely transparent — revealing the layers below it — or opaque, which keeps the layers below it hidden. You can vary the level of transparency too so that a layer can influence how much of the layers below are revealed.

**Blending modes** offer a way to combine layers. A blending mode (or mode) is a rule that describes how the lower layers are treated with respect to the active layer (the layer you are currently working with). In the pencil drawing example instructions on page 23, two modes are used:

- **Dodge mode**: enhances the detail in the darker parts of the image.
- **Multiply mode**: provides an effect like that of looking at the image through tinted glasses.

**Working with Filters**

As in real photography, digital imaging filters allow you to adjust lighting for your pictures. Using the GIMP, you can add or filter out light or apply shadows to your images.

The GIMP has dozens of filters. Among them is the Selective Gaussian Blur which allows you to blur the background of an image in order to make the foreground stand out. This filter is used in the example given later in this tutorial.

**Working with Color**

You can use the GIMP to create color artwork, color-correct a photo, or change a color image to black-and-white or grayscale. You can enhance your images by making subtle adjustments to hue, luminosity, saturation, and contrast. You can invert colors, so that colors are replaced by their color complements (in grayscale, black is swapped for white and vice-versa), and you can add texture and patterns. If you wish, you can remove color completely.
Getting Started

This section tells you how to start the GIMP, create a new file, open an existing file, use the undo function, save a file, and exit.

Starting the GIMP

To start the GIMP from your desktop, double-click on the GIMP icon.
The GIMP splash window briefly displays while the GIMP starts.

After a couple of seconds or less, three windows are displayed: the GIMP Image Manipulation Program window (hereafter referred to as the main window), the Toolbox, and the Layers dialog.

The main GIMP window is where your image is displayed. If you open more than one image file at a time, each will be displayed in its own main window. If you are creating a new image from scratch, the main window provides a blank canvas (working area) on which you can draw or paint.
The main window contains the menu options that provide the operations you’ll need to work with your image.

The Toolbox contains selection tools (operations that allow you to select parts of your image to work with) and transformation tools (for example, operations to move or rotate you image) and controls for using color.
The Layers dialog provides controls for managing layers. It displays the layer stack and indicates which layer is the active layer. From here you can adjust transparency, make your layers visible or invisible, and apply blending modes.

The controls in the Toolbox and the Layers Dialog are also available as menu options on the main window.
Creating a New File

Follow these instructions to create a new image file:

1. Using the main window, click File > New.

2. In the Create a New Image dialog, type values into the Width and Height fields, select the unit of measurement from the adjacent drop-down list, and click OK. When in doubt, specify your image dimensions in pixels.
**Opening a File**

Follow these instructions to open an existing file on your computer:

1. Using the main window, click **File > Open**. The Open Image dialog appears:

   ![Open Image Dialog](image)

   - **Places**: Click on a place in your computer where your image folders are located. The GIMP will display the list of folders under the **Name** heading. Alternatively, you can use the top row of buttons to locate folders.

2. Under **Places**, click on a place in your computer where your image folders are located. The GIMP will display the list of folders under the **Name** heading. Alternatively, you can use the top row of buttons to locate folders.
3. Double-click to select a folder and keep selecting folders until you have located your image file. (You may have to repeat selecting folders if you use subfolders.)

4. Click on the image file (the image will appear in the Preview area of the dialog), then click **Open**. The GIMP will display your image in the main window.

**Using Undo**

For all practical purposes, the GIMP supports an unlimited level of undo. This means that should you want to back out an editing operation, revert to a previous version of your image, experiment with effects, or simply correct a mistake, you can do so easily.

To undo the last operation, click **Edit > Undo** in the main window.
Saving a File

If you have opened an existing file and want to save your image in the same file, click **File > Save**.

If you want to save your image in a new file, follow these instructions:

1. Using the main window, click **File > Save As**. The Save Image dialog appears:
2. Under Places, click on a place in your computer where you image folders are located. The GIMP will display the list the folders under the Name heading. Alternatively, you can use the top row of buttons to locate folders.

3. Double-click to select a folder and keep selecting folders until you have located the one in which you want to save your image. (You may have to repeat selecting folders if you use subfolders.)

4. In the Name field at the top of the menu, type in a filename including the file extension (.jpg for JPEG or .gif for GIF), and click Save.

5. Depending on which file extension you type, another dialog will display. In either case, click Save.

![Save as JPEG Dialog](image)
Exiting the GIMP

To exit the GIMP, click **File > Quit**. If you have open unsaved files, you’ll be prompted to save the files or to discard the changes before the GIMP exits.
Creating a Pencil Sketch from a Photo

This section gives step-by-step instructions for creating a pencil sketch from a photo. This example demonstrates the use of layers, blending modes, color, and filters.

Before you begin, choose a color picture or photo that already resides on your computer. This example starts with the following image:
Follow these instructions to turn a color photo into a pencil drawing:

1. Start the GIMP, open your image file (see page 17), and click Layer > Duplicate Layer. The GIMP creates a new layer called “background copy” and makes it visible in the Layer window.

Alternatively, you can accomplish the same step using the Layers dialog. The layer stack contains a row for each layer, represented as thumbnail images. (The eye icon indicates that the layer is visible.) Right-click on the top layer, then from the pop-up menu click Duplicate Layer.
2. Using the main window, click **Colors > Colorize**. Using the Colorize dialog, slide the **Saturation** control all the way to the left until the value shown in the field next to it is zero, then click **OK**. The GIMP removes the color from the active (top) layer, leaving you with a black-and-white version of your image.
3. Using the main window, click Layer > Duplicate Layer, then apply a filter to give the image a blurred effect. Click Filters > Blur > Selective Gaussian Blur, and using the Selective Gaussian Blur dialog, check the preview checkbox, type 5 into the Blur radius field, type 50 into the Max Delta field to the right of the slider, and click OK.
4. Using the main window, click **Colors > Invert**. The black pixels turn white, and the white pixels turn black, giving the image the appearance of a film negative.
5. Using the Layers dialog, change the opacity value to 50%. You can do this in one of two ways: use the mouse to drag the slider until 50 appears in the field beside it, or type 50 directly into the field. The image in the main window will show very faint lines against a gray background.

6. Using the Layers dialog, position your mouse on the top layer and right-click. Using the pop-up menu, click **Merge Down**. The GIMP merges the top two layers so you now have two layers instead of three.

7. Apply the first blending mode to the image: Using the main window, click **Layer > Duplicate**. Using the Layers dialog, select **Dodge** from the Mode drop-down list at the top of the dialog. Using the main window, click **Layer > Merge Down**.
8. Apply the second blending mode to the image: Using the main window, click **Layer > Duplicate**. Using the Layers dialog, select **Multiply** from the Mode drop-down list. Using the main window, click **Layer > Merge Down**.

9. Save the image into a new file (see page 19).
Index

A
active layer, 15

B
Blending modes, 9

C
canvas, 12
color, 9
creating files, 16

digital editing, 7
Dodge mode, 9
download, 6

E
exiting the GIMP, 21

F
file types, 8
files
creating, 16
extensions, 20
opening, 17
saving, 19
types of, 7

G
GIF, 7
GIMP icon, 11

I
installing the GIMP, 6

J
JPEG, 7

L
layers
active, 15
definition, 8
managing, 15
Layers dialog, 15
Linux, 5

M
Mac OS, 5
main window, 12
managing layers, 15
Multiply mode, 9

O
opacity, 28
opening files, 17
operating systems, 5

P
pencil sketch, 5
PNG, 7

Q
quitting the GIMP, 19
S
saving files, 19
selection tools, 13
Selective Gaussian Blur, 9
splash window, 12
starting the GIMP, 11
system requirements, 6

T
Toolbox, 13
transformation tools, 13

U
undo, 18
Unix, 5

W
Windows XP, 5

X
XCF, 8
The GIMP is a GNU Image Manipulation Program.
It is freely distributed software.

0820-6371188